Вопросы Влад Чепурнов
150

Проблема с Alchemy [решено]

Не могу разобраться с Java Runtime Environment

В закладки

Нашёл на просторах интернета интересную прогу - Alchemy. Если вкратце - генератор творческого беспорядка чтобы далее его "упорядочить" и что-то из этого создать. Или же когда охота порисовать, а идей в голове нет.

Работает она на Java. И в этом проблема. При запуске она мне пишет:

"This application requires a Java Runtime Environment 1.5.0

И один вариант ответа - Ok.

Хотел прикрепить картинку, но она почему-то не прогружается.

И я не понимаю, что она от меня хочет. При нажатии на Ok кидает на сайт установки Java. Я скачиваю оттуда новую версию (8 211), но к иному результату она не приводит.

Я так понимаю, мне нужно найти именно Java Runtime Environment? Или тут проблема в другом?

Вопрос решён. Решением послужило удаление предыдущей Java и установка 64-битной версии. Большое спасибо за помощь Тимуру Богданову :)

Материал опубликован пользователем. Нажмите кнопку «Написать», чтобы поделиться мнением или рассказать о своём проекте.

Написать
{ "author_name": "Влад Чепурнов", "author_type": "self", "tags": [], "comments": 19, "likes": 2, "favorites": 2, "is_advertisement": false, "subsite_label": "ask", "id": 57121, "is_wide": false, "is_ugc": true, "date": "Tue, 02 Jul 2019 21:25:27 +0300" }
{ "id": 57121, "author_id": 103889, "diff_limit": 1000, "urls": {"diff":"\/comments\/57121\/get","add":"\/comments\/57121\/add","edit":"\/comments\/edit","remove":"\/admin\/comments\/remove","pin":"\/admin\/comments\/pin","get4edit":"\/comments\/get4edit","complain":"\/comments\/complain","load_more":"\/comments\/loading\/57121"}, "attach_limit": 2, "max_comment_text_length": 5000, "subsite_id": 64961, "last_count_and_date": null }
19 комментариев

Популярные

По порядку

Написать комментарий...
4

1. Проверьте, что поставили именно JRE (хотя в JDK входят нужные вам файлы из JRE, вам весь JDK не нужен)

2. Проверьте, что система находит JRE. Вбейте в cmd команду java -version. Должно выйти что-то подобное:
C:\Users\(пользователь)>java -version

java version "1.8.0_201"

Java(TM) SE Runtime Environment (build 1.8.0_201-b09)

Java HotSpot(TM) 64-Bit Server VM (build 25.201-b09, mixed mode)

3. Если выводится "java не является внутренней или внешней программой", то в переменную среды PATH допишите после точки с запятой путь до папки с java.exe. У меня этот путь выглядит так:
C:\Program Files (x86)\Common Files\Oracle\Java\javapath

Возможно, тот же путь придётся вбить в новую переменную среды JAVA_HOME.
Для того, чтобы изменения вступили в силу, нужно будет перезагрузиться.

4. И только если вообще ничего не подходит (при этом вы прописали путь и пункт 2 выводит правильное, но игра всё равно отказывается), то поискать JRE для Java 5 (т.е. версии 1.5) Надеюсь, к этому прибегать не придётся, потому что обратная совместимость в новых версиях быть должна. Лучше уж поискать альтернативу самой игре или её версии, как сказал Igor.

Ответить
0

Я так понимаю, проблема в слишком новой версии. Мне нужно снести новую и поставить старую. Но ради одной проги устанавливать такую старую версию не особо хочется

Ответить
1

Кстати говоря! Нашёл гитхаб:
https://github.com/karldd/Alchemy
Там есть версии поновее, от 2010 года. Требуется JRE версии "1.5.0 or above". Может быть такое, что прога ищет джаву где-то не там? Попробуйте новую версию из папки Releases:
https://github.com/karldd/Alchemy/blob/master/releases/Alchemy-008.zip
Если у вас есть опыт в программировании, то можно попробовать собрать прогу из исходников (с IDE или без), но для этого понадобится установить JDK, а не JRE.

И в какой директории лежит сама программа? В пути есть кириллица?
Windows users please make sure the path to Alchemy does not contain any non-standard characters such as the exclamation mark (!), this has been known to cause problems launching the application. If your user name has non-standard characters, try putting Alchemy directly into the root directory.

Ответить
0

Понял, посмотрю.
В коддинге опыта нет)
Проверял, кириллица проблемой не является

Ответить
0

We use the NetBeans IDE and include the Netbeans project files in the repository. Using the build.xml file supplied and NetBeans, everything should compile straight away on all platforms. The only dependency is Lauch4j to create .exe files for distribution on Windows.

Если уж ОЧЕНЬ нужно, то поставьте JDK и NetBeans, скачайте проект и попробуйте собрать его в этой IDE. Если вам сильно повезёт, то сборка пройдёт нажатием одной кнопки Build. Запускать .jar и .class файлы можно командами java -jar (файл с .jar) и java -cp . (название файла без .class c большой буквы) соотв-но

Ответить
0

Установил 5 версию. Прочекал через командную строку - всё верно пишет, но прога неумолимо отвечает всё то же самое. Качаю NetBeans - попробую собрать. (ну как, по кнопкам поклацаю, вдруг что сработает))

Ответить
1

Могу попробовать собрать сам с Java 8 под 64-битную винду, если хотите. Но ничего не гарантирую.

Ответить
0

Было бы отлично) Я понимаю

Ответить
0

У вас есть аккаунт в Discord/Telegram? Чтобы можно было не переписываться тут в комментариях. Я сейчас ради интереса запустил последнюю версию с гитхаба и она пошла без дополнительной сборки. Возможно, у вас что-то не то с установкой JRE.

Ответить
0

Да, Дискорд есть. Flincherbach#6119

Ответить
3

Так скачай и установи. Только проверь что качаешь. Тебе нужен jre , не jdk.
Возможно придётся вручную прописать переменные окружения PATH и вроде JAVA_PATH - тут уже от ОС зависит способ. Можно раскурить мануал у ораклов на сайте

Ответить
2

Чтобы проверить, установлена ли Java, открой командную строку и выполни

java -version

Если Java установлена, то увидишь что-то типа:

Java(TM) SE Runtime Environment (build 9+181)

P.S. Судя по их сайту, Alchemy не обновлялся с 2014 года. Ты уверен, что тебе нужна эта программа? Может лучше поискать аналоги?

Ответить
0

Аналоги искал, но не нашёл.
А с командной строке пишут это:
java version 9.0.4
Java (TM) SE Runtime Environment (build 9.0.4+11)
Java HotSpot (TM) 64-bit Server VM (build 9.0.4+11, mixed mode)

Ответить
1

норм всё, значит. Странно, что игра не пашет.

Ответить
1

Судя по ошибке, требуется совсем не новая версия джавы. На сайте oracle есть страница java archive, там есть 5 версия. Но, как там и написано, в ней нет последних патчей безопасности, всё делается на свой страх и риск.

Ответить
0

Откуда, что именно качал?

Ответить
0

В гипертексте, на слове Java

Ответить
0

Качайте jre а не jdk

Ответить
0

Прямой эфир

{ "remaining": "WzAsMSwyLDMsNCw1LDYsNyw4LDld" } [ { "id": 1, "label": "100%×150_Branding_desktop", "provider": "adfox", "adaptive": [ "desktop" ], "adfox_method": "createAdaptive", "auto_reload": true, "adfox": { "ownerId": 228129, "params": { "pp": "g", "ps": "clmf", "p2": "ezfl" } } }, { "id": 2, "label": "1200х400", "provider": "adfox", "adaptive": [ "phone" ], "auto_reload": true, "adfox": { "ownerId": 228129, "params": { "pp": "g", "ps": "clmf", "p2": "ezfn" } } }, { "id": 3, "label": "240х200 _ТГБ_desktop", "provider": "adfox", "adaptive": [ "desktop" ], "adfox": { "ownerId": 228129, "params": { "pp": "g", "ps": "clmf", "p2": "fizc" } } }, { "id": 4, "label": "240х200_mobile", "provider": "adfox", "adaptive": [ "phone" ], "adfox": { "ownerId": 228129, "params": { "pp": "g", "ps": "clmf", "p2": "flbq" } } }, { "id": 5, "label": "300x500_desktop", "provider": "adfox", "adaptive": [ "desktop" ], "adfox": { "ownerId": 228129, "params": { "pp": "g", "ps": "clmf", "p2": "ezfk" } } }, { "id": 6, "label": "1180х250_Interpool_баннер над комментариями_Desktop", "provider": "adfox", "adaptive": [ "desktop" ], "adfox": { "ownerId": 228129, "params": { "pp": "h", "ps": "clmf", "p2": "ffyh" } } }, { "id": 7, "label": "Article Footer 100%_desktop_mobile", "provider": "adfox", "adaptive": [ "desktop", "tablet", "phone" ], "adfox": { "ownerId": 228129, "params": { "pp": "g", "ps": "clmf", "p2": "fjxb" } } }, { "id": 8, "label": "Fullscreen Desktop", "provider": "adfox", "adaptive": [ "desktop", "tablet" ], "auto_reload": true, "adfox": { "ownerId": 228129, "params": { "pp": "g", "ps": "clmf", "p2": "fjoh" } } }, { "id": 9, "label": "Fullscreen Mobile", "provider": "adfox", "adaptive": [ "phone" ], "auto_reload": true, "adfox": { "ownerId": 228129, "params": { "pp": "g", "ps": "clmf", "p2": "fjog" } } }, { "id": 10, "label": "Native Partner Desktop", "provider": "adfox", "adaptive": [ "desktop", "tablet" ], "adfox": { "ownerId": 228129, "params": { "pp": "g", "ps": "clmf", "p2": "fmyb" } } }, { "id": 11, "label": "Native Partner Mobile", "provider": "adfox", "adaptive": [ "phone" ], "adfox": { "ownerId": 228129, "params": { "pp": "g", "ps": "clmf", "p2": "fmyc" } } }, { "id": 12, "label": "Кнопка в шапке", "provider": "adfox", "adaptive": [ "desktop", "tablet" ], "adfox": { "ownerId": 228129, "params": { "pp": "g", "ps": "clmf", "p2": "fdhx" } } }, { "id": 13, "label": "DM InPage Video PartnerCode", "provider": "adfox", "adaptive": [ "desktop", "tablet", "phone" ], "adfox_method": "createAdaptive", "adfox": { "ownerId": 228129, "params": { "pp": "h", "ps": "clmf", "p2": "flvn" } } }, { "id": 14, "label": "Yandex context video banner", "provider": "yandex", "yandex": { "block_id": "VI-250597-0", "render_to": "inpage_VI-250597-0-1134314964", "adfox_url": "//ads.adfox.ru/228129/getCode?pp=h&ps=clmf&p2=fpjw&puid1=&puid2=&puid3=&puid4=&puid8=&puid9=&puid10=&puid21=&puid22=&puid31=&puid32=&puid33=&fmt=1&dl={REFERER}&pr=" } }, { "id": 15, "label": "Плашка на главной", "provider": "adfox", "adaptive": [ "desktop", "tablet", "phone" ], "adfox": { "ownerId": 228129, "params": { "p1": "byudo", "p2": "ftjf" } } }, { "id": 17, "label": "Stratum Desktop", "provider": "adfox", "adaptive": [ "desktop" ], "auto_reload": true, "adfox": { "ownerId": 228129, "params": { "pp": "g", "ps": "clmf", "p2": "fzvb" } } }, { "id": 18, "label": "Stratum Mobile", "provider": "adfox", "adaptive": [ "tablet", "phone" ], "auto_reload": true, "adfox": { "ownerId": 228129, "params": { "pp": "g", "ps": "clmf", "p2": "fzvc" } } } ]
Уве Болл вернулся в кино
и начал экранизировать flash-игры
Подписаться на push-уведомления